Daml start: Not in project


So being into crypto, I was influenced by a Corda developer talking about my favorite coins, and the technology underlying those coins. I realized I need to learn this language. Thing is, I have a systems/networking background, and can’t help but feel really stupid. I’m using windows 10, followed the instructions, but whenever I enter ‘daml start’ I get the aforementioned error message. I tried to figure it on my own, and I’m stumped. searched the forum for someone having a similar issue, and didn’t see it.

So if anyone can give me a break as I begin this career pivot, I would really, really appreciate it. :sweat_smile:


I believe that would happen if you are not in a Daml project directory, one with a daml.yaml file in it.

> daml new foo
Created a new project in "foo" based on the template "skeleton".
> daml start
daml start: Not in project.
> cd foo
> daml start
Compiling foo to a DAR.
Created .daml/dist/foo-0.0.1.dar
Waiting for sandbox to start: 

Does this solve your problem?


Stefano, thanks a lot man. Problem solved!


Welcome to the Daml community @Feltima!

One of our goals with this community is to cater to all levels of developers. If you’ve tried to find an answer to your question and haven’t, don’t feel stupid about asking questions no matter how basic you think they are.

All great software products and communities are built one user question after another, and your question gives us an opportunity to improve Daml (maybe we can change the error message to be clearer and suggest the fix) and in any case the next person who will stumble upon this problem will find the answer much faster.

So thanks for contributing, it’s great to have you as part of our community!