Navigator showing unknown templates

Hi DAML Community,

I have recently updated my project to the DAML SDK Version 2.0.0 and have noticed a few extra tables have showed up in the Navigator. When, I run the command daml start with the navigator, the following templates have now been added to the screen:

I ran the daml damlc inspect-dar on the generated dar but could not find any dependencies that match the package hash code 65921e553a353588e950cbc87e98a127730e63295f7ad8d3adae952ef0133b3e. Is this a bug or am I building the project with the PingPong dependency?

On a similar but different topic, I am trying to create a simple canton infrastructure using the canton-community:dev docker image. I created a participant and domain node in two different containers and verified that they could connect to each other and that the dars have been uploaded correctly. In a seperate container (using digitalasset/daml-sdk:2.0.0) I started the daml navigator and routed it to the participant node through the configured ledger-api port. However, when I visited the navigator page I could not see any templates from the package that I had uploaded to the participant. The navigator correctly populates the users so I know that it is able to connect to the party management service. Do you know what the cause of this may be?

Canton (and therefore also the Canton sandbox) includes a few packages by default. Those are the additional packages you see here.

1 Like

Thanks for the response!

Is there a way to remove these packages?

I am still also unable to get my templates to load on the navigator using a canton docker image.

No, you cannot remove them.

I am still also unable to get my templates to load on the navigator using a canton docker image.

Can you explain what the issue is? I don’t see how the additional templates prevent you from that.

Sorry, there was something wrong with my docker volumes configuration.

It was unrelated to the extra templates, just wanted to check that I had the right setup. I have managed to get it working now, so no worries.

1 Like

Hi @benedict_chan and welcome to the Daml community!
I’ve added a feature request to allow you to filter out the default templates in Navigator.

1 Like