GRPCIOTimeout with daml deploy when running within a docker container

Thanks!

I get “daml-helper: GRPCIOTimeout” after a few seconds when running daml deploy targeting daml-on-sql running in a Docker container and nothing logged.
Is there a way to turn up logging?

Per

1 Like
$ ls -ld .daml/dist/carbon-0.0.1.dar
-rw-r--r--  1 Per.Bergman  staff  303669 Apr 29 09:27 .daml/dist/carbon-0.0.1.dar


$ daml git:(perbergman/DAML-05) ✗ daml ledger upload-dar  --access-token-file="security/certs/jwt/system.token" --timeout 1200  --max-inbound-message-size 4000000

Compiling carbon to a DAR.
Created .daml/dist/carbon-0.0.1.dar
Uploading .daml/dist/carbon-0.0.1.dar to localhost:6865
An exception was thrown during the upload-dar command
- GRPCIOTimeout
One reason for this to occur is if the size of DAR file being uploaded exceeds the gRPC maximum message size. The default value for this is 4Mb, but it may be increased when the ledger is (re)started. Please check with your ledger operator.
1 Like

The daml-on-sql process is binding to localhost by default, which, in a Docker container, means it will only accept connections coming from within the same Docker container. If you want it to accept connections from anything else, you’ll need to pass the --address argument, likely --address 0.0.0.0 in this context (i.e. accept connections from any network interface).

2 Likes

Ah! Thanks!

I have that option elsewhere but did not include it this time.

3 Likes