Getting error in UI application

I have implemented a sample DAML app and am trying to deploy it on Canton. I have used daml codegen js command to generate the UI code. The daml code is working fine on Navigator but not in Canton.
I followed the below steps:

  1. Start the Canton network
  2. Start the JSON API
  3. Start UI as participant1
    At the time of login, I am getting the below error

Hi, Arijit

Canton Network is permissioned for now; it will become open to the general public in the future.

If you’d like to learn more about whether your organization has access to the Canton Network, please reach out to me directly via email.

Wayne Collier
Principal Product Manager, Canton Network

Hello Wayne,
I am following this tutorial. Basically, it’s not the Canton network; I am trying to execute my DAML app on Canton.

Hi @arijitltim,

My reproduction attempt was unsuccessful. Can you give us more information on where you might have deviated from the description? You mentioned that your Daml app works in the Navigator. Where in the process did you start that? Have you tried the tutorial with the example it refers to? Did everything work fine then?


Hello Peter,
Is there anyway I can share the project with you? My Daml app is working fine on Navigator but not on the Canton network.
I tried the Daml app on Navigator first, then I tried to deploy it on the Canton. The Canton is running fine, but I am getting errors in the UI.

Hi @arijitltim,

You can upload here or share a link to github or file sharing.

Hello Peter,
I have uploaded the daml code and also the Canton configuration.

Please check the below folder structure. You can place the daml folder inside create-daml-app and generate the UI by executing the command - daml codegen js. (1.7 KB) (1017 Bytes)

I too tried to reproduce the issue. I used your zip files. I was able to successfully sign in as “acme”.


Here are some big picture things to keep in mind.

  • Calling daml codegen js does not really “generate the UI”. It creates a JS library for interacting with your contracts on the ledger. But, the UI is not auto-generated. In other words, just because you created new LoanRequest and SyndicatePledge templates, those will not be available in the create-daml-app demo. The create-daml-app tutorial code.

  • Navigator is a little different. Navigator is a browser UI that knows how to interact with arbitrary templates/contracts. That’s why when you say, “The daml code is working fine on Navigator…” that makes sense. Your LoanRequest and SyndicatePledge templates will appear in Navigator. They will not appear in the create-daml-app demo (unless you update the React code to use them.)

I don’t know if the above helps clarify anything. I hope so.

Why you are seeing the “Unknown error:” in the Canton version of the create-daml-app tutorial is still a mystery. Let us know if you see anything else that might be a clue.