Testing Deduplication and receiving DEADLINE_EXCEEDED error


I am trying to test Deduplication on daml sandbox 2.2.1. While submitting commands with same command Id, I am getting grpc status DEADLINE_EXCEEDED while using command service and NO_RESPONSE while using command submission/completion service instead of ALREADY_EXISTS (DUPLICATE_COMMAND(10)).

c.a.d.i.t.u.services.CommandService - java.util.concurrent.ExecutionException: io.grpc.StatusRuntimeException: DEADLINE_EXCEEDED: REQUEST_TIME_OUT(3,703a58ce): Timed out while awaiting for a completion corr
esponding to a command submission

NOTE: This only happens when we use the sandbox with static time.

Any suggestions? Thankyou!

Hi @Pal.Gajinder

I modified your Subject line to something a little more concise :grinning:

Have you tried this deduplication testing, without the --static-time flag on the Sandbox?

If so, what was the result? Same?

Hi @Ben_M,

Thanks. I have also tried it without --static-time flag and it is working as expected giving ALREADY_EXISTS (DUPLICATE_COMMAND(10)) status code.