Daml hub quirks

Hello everyone,

While attempting some tests on the daml hub platform I encountered a couple of issues I wanted to address here:

  • Firtsly, while creating a contract, in which one of the fields is a list of a custom data type, if no element is added to said list, the fields wasn’t passed on to the request at all and I received an error with the following output:
JsonError: spray.json.DeserializationException: Can't read { ... } as DamlLfRecord Foo, missing field 'field'
  • The second issue was that sometimes, when creating contracts/exercising choices, updating fields on the UI wasn’t being reflected on the payload of the request going through.

  • Finally, whevener I tried using the search bar feature to look up a template Id or contract Id, I would get redirected to the following page.

Thank you in advance.

1 Like

Thank you very much for reporting! We’ll look into these issues and fix them ASAP!


Hi, is there an estimate upon which the topics raised are fixed, or are they fixed already?



The issues raised have been logged internally, however they have not all been fixed. I will personally take responsibility for these in the next few days.

Apologies for the delay,



Thank you @sarah.breckenridge :+1:


Fixes for the above issues have been committed to our repo and will go live in the console at the time of our next production release.

If the second issue you described happens again, feel free to ping this thread with details as to what changes are not being reflected in the payload of your request. That way I can take care of any remaining issues you may be experiencing.

Thank you for your patience with these fixes and have a nice weekend,


1 Like

Thank you @sarah.breckenridge,

As a final remark, could you specify the currently expected schedule to release these fixes into production?
We’ve noticed somewhat of a pattern in the announcements which seemed to indicate a monthly release (Announcements - Daml Developers Community). Can we expect a release in the next few days given this?

Would it also be possible/feasible to have an available schedule of expected releases into Daml Hub at an earlier stage?



After speaking with our project manager, we will work on a published update schedule which should give a longer view soon. Otherwise, the quirks pointed out at the origin of this thread have been solved for and are in our production environment.

Thanks, and let me know if I can help with anything else -


1 Like

Hey Luis,

As Sarah says, we’ll work on publishing a longer looking release and update schedule soon.

Thanks, David.

1 Like


This issue seems to not have been fully fixed.
Please find below an example of a complex data type with a similar structure to where we tested out these situations.

       "description":"Event description",
         "op":[""],"name":"X","id":"3","order":"1"},{        <- op and id did not update correctly upon change
       "Date":"2022-05 16T23:00:00.000Z",
       "Payload":"qwerty", <- tried to change from value presented to "{}" and didn't change on request

What we’re witnessing is that, when updating the various inputs required on the UI, the changes done don’t match what gets sent out to the HTTP JSON API.


  • Select boxes do not correctly update the value - option is changed and is not reflected on the request
  • Text fields do not update the full string - where on the UI it shows “3333” it got translated into the request as “33” or sometimes even just “3”
  • No item was added to a list and the request that got sent had an item in it
  • Added item to a list and then removed and it was still sent on the request


Thanks for sending the data type - that is super helpful. If you are able to send the .dar or daml contract for which you are seeing these issues, that would also be helpful!

A few follow up questions:

  • for the select box case, is this when an optional input is rendered? What kind of select box?
  • for the text fields, does this happen every time? Or only when the text is nested in another type?
  • for the empty list, what item does the list get sent with? An empty string?

Thanks for your patience and help with this!