Canton AWS Deployment

Hi everyone!

I tried deployment example from the GitHub Canton repo and faced a few problems.

First, if I run from this template source, as it is written in the instructions

I got an error on the Postgres resource creation:

Cannot find version 12.5 for postgres

I found out that this particular version was deprecated. After running this command

aws rds describe-db-engine-versions --engine postgres --output table 

I found the closest supported version is 12.7. So I changed the template accordingly and ran the updated stack. Now there are no errors but a lot of events are in CREATE_IN_PROGRESS status. And the whole stack is in CREATE_IN_PROGRESS status for several hours already. The “Outputs” tab is empty.
I’m relatively new to AWS, what can be wrong here?
From the “Resources” tab I see that these two resources are hanging


Hi Victor,
The cloud deployment example you tried to followed is out-of-date. Please refer to the reply to your previous forum topic.

1 Like